Error del agente FlowActionBadRequest en los canales

Resumen

Este artículo le ayuda a resolver el error FlowActionBadRequest que se produce en los canales, como Microsoft Teams, cuando un agente de Microsoft Copilot Studio invoca un flujo de Power Automate. El error suele deberse a errores de coincidencia de esquema de entrada o salida en las acciones de flujo.

Síntomas

Al interactuar con un agente de Copilot Studio integrado con flujos de Power Automate en canales como Microsoft Teams, recibirá el siguiente mensaje de error:

FlowActionBadRequest Conversation Id: xxxxxx_rYcg4Z9DFNp_rP-RkQraV5IPMFu-KRlt4UE Time (UTC): 2024-12-02T00:44:24.873Z.

Causa

Este error se produce debido a una discrepancia de esquema entre los parámetros de entrada o salida del flujo y lo que espera el agente. El error se produce a menudo al modificar el flujo en Copilot Studio, pero no actualiza ni vuelve a publicar los cambios. Por lo tanto, Teams envía o recibe formatos de datos inesperados. Los valores de entrada que faltan o null también pueden desencadenar este error.

Solución

Refrescar y actualizar el flujo en Copilot Studio

La corrección más común es actualizar el flujo en Copilot Studio para que el esquema de entrada y salida coincida con el agente:

  1. Abra el tema que contiene el flujo en Copilot Studio.

  2. Seleccione los puntos suspensivos (...) en el nodo Acción y, a continuación, seleccione Actualizar.

    Captura de pantalla de un tema que se centra en un nodo Acción y resalta la opción Actualizar del nodo.

  3. Compruebe que los parámetros de entrada y salida de Copilot Studio coinciden con los parámetros de Power Automate.

  4. Guarde y vuelva a publicar el agente.

Comprueba si hay valores de entrada nulos

Si el error persiste después de actualizar el flujo, compruebe que los parámetros de entrada que se pasan desde el agente de Copilot Studio al flujo de Power Automate son válidos.

  1. Compare los valores de entrada en Copilot Studio y en Power Automate para identificar discrepancias:

    Captura de pantalla de un nodo De acción de Copilot Studio, en la que se resaltan las entradas de Power Automate.

    Captura de pantalla del flujo de Power Automate, donde se resalta lo que el agente realiza cuando se llama al flujo.

  2. Si algún valor de entrada es NULL, agregue una acción Mensaje en el flujo para capturar y devolver los valores de entrada. Este paso le ayuda a depurar y comprobar los datos que se devuelven a Teams.

  3. Agregue lógica o expresiones en el flujo para controlar entradas nulas o que falten.

Refrescar la conversación en Microsoft Teams

A veces, Microsoft Teams almacena en caché una versión obsoleta de la conversación del agente. Este almacenamiento en caché puede provocar que el error persista incluso después de completar los pasos anteriores.

  1. En el chat de Teams con el agente, escriba start over, goodbye u otra frase que desencadene el tema de fin de conversación.

  2. Inicie una nueva conversación para cargar la versión más reciente del flujo.

Borrar el estado de la conversación

Si los pasos anteriores no resuelven el problema, borre el estado de la conversación en Teams. En el chat de Teams con el agente, escriba /debug clearstate para restablecer el contexto de conversación y forzar a Teams a volver a cargar el estado del agente.