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Gilt für: Windows ✔️ VMs
Zusammenfassung
Dieser Artikel enthält eine Lösung für ein doppeltes Clientcomputer-ID-Problem, das auftritt, wenn Sie einen selbst gehosteten KMS-Server (Key Management Services) für Windows Aktivierung verwenden.
Es wird im Allgemeinen empfohlen, Azure KMS-Server (Key Management Services) zu verwenden, um Azure Windows virtuellen Computer (VMs) zu aktivieren, auch wenn Azure-Hybridvorteil aktiviert ist. Da Netzwerkeinschränkungen jedoch in bestimmten Fällen verhindern können, dass VMs mit Azure KMS-Servern kommunizieren, können Sie einen selbst gehosteten KMS-Server für die Aktivierung verwenden. In diesem Artikel wird ein Problem der doppelten Clientcomputer-ID erläutert, das auftritt, wenn Sie einen selbst gehosteten KMS-Server für Windows Aktivierung verwenden und eine Lösung bereitstellen.
Notiz
Dieser Artikel gilt nur, wenn Sie einen selbst gehosteten KMS-Server für die Aktivierung verwenden. Sie gilt nicht, wenn Sie Azure KMS für die Aktivierung verwenden.
Von Bedeutung
Wenn bei Azure-VMs (virtuellen Maschinen) Windows-Aktivierungsprobleme auftreten, lesen Sie Problembehandlungstools für Windows-Aktivierungsprobleme auf virtuellen Azure-Computern.
Symptome
Wenn Sie einen selbst gehosteten KMS-Server für die Aktivierung verwenden und versuchen, mehrere Windows Server VM zu aktivieren, schlägt die Aktivierung nach dem Auswertungszeitraum fehl, und Ihr selbst gehosteter KMS-Server meldet den folgenden Fehler im Duplicate Client Machine ID Report:
Der Bericht "Doppelte Clientcomputer-ID" hilft, Computer in der Umgebung zu identifizieren, die Images ausführen, die vor der Bereitstellung nicht ordnungsgemäß generalisiert wurden, indem sie das Sysprep-Tool verwenden.
Hinweis:
- Mehrere Volumenaktivierungsclients mit derselben CMID werden von KMS als einzelner Client gezählt. Wenn dadurch die KMS-Clientanzahl unter den Minimalschwellenwert fällt, schlägt die KMS-Aktivierung in Ihrer Umgebung fehl.
Ursache
Die Clientcomputer-ID (CMID) wird während des Sysprep-Prozesses des ursprünglichen Quellimages gelöscht. Wenn der Sysprep-Prozess jedoch mit dem Parameter
SkipRearmausgelöst wird, der auf1anstelle des Standardwerts0festgelegt ist, wird die CMID nicht gelöscht. In diesem Fall haben alle virtuellen Computer, die aus diesem Image erstellt wurden, die gleiche CMID.Wenn Sie VMs aus Azure Marketplace erstellen, wurden Azure Marketplace Images für Windows Server generalisiert, wobei der Parameter
SkipRearmauf1festgelegt wurde. Daher weisen die virtuellen Computer, die mit demselben Windows Server Image erstellt wurden, dieselbe CMID auf.
Duplikat CMID bestätigen
Überprüfen Sie, ob die virtuellen Computer die gleiche CMID basierend auf dem Quellimage und der gleichen Version haben:
Führen Sie den folgenden Befehl auf den problematischen virtuellen Computern aus:
cscript C:\Windows\System32\slmgr.vbs /dlvHier ist ein Befehlsausgabebeispiel:
Most recent activation information: Key Management Service client information Client Machine ID (CMID): <client-machine-ID> Registered KMS machine name: <KMS-machine-name>Vergleichen Sie die Befehlsausgabe für die problematischen virtuellen Computer, und bestätigen Sie, ob die virtuellen Computer dieselbe CMID haben.
Lösung
Für die problematischen VMs, die aus einem benutzerdefinierten Image erstellt wurden, generalisieren/sysprep die ursprüngliche VM mit dem Parameter
SkipRearm, um0sicherzustellen, dass die CMID aus dem Image gelöscht wird.Führen Sie für die problematischen virtuellen Computer, die bereits bereitgestellt wurden, die folgenden Schritte aus:
Führen Sie den Befehl
slmgr /rearman einer Eingabeaufforderung mit erhöhten Rechten aus.Starten Sie den virtuellen Computer neu.
Nachdem der virtuelle Computer nach dem Neustart online ist, führen Sie den folgenden Befehl aus, um zu bestätigen, dass die CMID geändert wurde:
cscript C:\Windows\System32\slmgr.vbs /dlvFühren Sie die Aktivierung erneut durch.